Mykinsta file manager issue with uploading larger files

Incident Report for Kinsta

Update

We are still investigating the issue. Thank you for your patience.
Posted Aug 19, 2026 - 14:18 UTC

Update

We are still investigating the issue. Thank you for your patience.
Posted Aug 19, 2026 - 08:06 UTC

Update

We are still investigating the issue. Thank you for your patience.
Posted Aug 18, 2026 - 14:16 UTC

Update

Our engineers are continuing to investigate into the issue. We apologize for any inconvenience this causes.
Posted Aug 17, 2026 - 01:42 UTC

Update

Our engineers are continuing to investigate into the issue. We apologize for any inconvenience.
Posted Aug 16, 2026 - 03:43 UTC

Update

Our engineers are continuing to investigate into the issue. We apologize for any inconvenience.
Posted Aug 15, 2026 - 17:46 UTC

Update

The issue is still being investigated by our engineers.
Posted Aug 14, 2026 - 13:55 UTC

Update

We are continuing to investigate the issue and apologize for the inconvenience.
Posted Aug 14, 2026 - 05:36 UTC

Update

We are continuing to investigate the issue.
Posted Aug 13, 2026 - 14:01 UTC

Update

We are continuing to investigate the issue.
Posted Aug 13, 2026 - 01:17 UTC

Update

We are continuing to investigate the issue.
Posted Aug 12, 2026 - 13:52 UTC

Update

We are continuing to investigate the issue.
Posted Aug 12, 2026 - 01:55 UTC

Update

We are continuing to investigate the issue.
Posted Aug 11, 2026 - 14:03 UTC

Investigating

We are currently investigating reports of issues with uploading larger files (100+ MB).
Posted Aug 11, 2026 - 09:02 UTC
This incident affects: MyKinsta.